Brauche Hilfe bei Magix Video Deluxe

  • Erstmal Allen ein Frohes Neues Jahr!!!!


    Ich habe schon öfters versucht mich in Magix Video Deluxe einzuarbeiten und da ich momentan ein bischen Zeit habe, starte ich einen neuen Versuch und habe gleich Schwierigkeiten.


    Ich will eine mkv Datei importieren, die ein Video mit 720p enthält. Also habe ich erst den mkv File in einen ..h264 video file entpackt und dann mit dem tsmuxer in eine ts Datei umgewandelt. Magix lädt diesen File auch, aber leider ist das Video nur 1 sec lang, obwohl der h264 File über 1,5 GB ist und sich problemlos abspielt. Auch wenn ich mit dem Tsmuxer eine m2ts Datei erstelle klappt es nicht.


    Warum??? Liegt es an windows oder was mach ich falsch 7??

  • Versuch mal mit mkvMerge Gui nur die Videospur zu extrahieren und mit dieser zu arbeiten, wenn es dir reicht. Wenn nicht, dann extrahierst du aus der mkv das Video und den Ton und lädst diese einzeln rein, falls das klappt. ;)

  • Ramses-Pharao:


    Du solltest auch erwähnen, was genau Du damit in Magix machen willst. Willst Du dubben oder etwas anderes? Um auf ein US-720p mkv zu dubben, lade ich z. B. nicht dieses ins Magix sondern trenne es im tsMuxer in .h264 und .ac3 und schmeiße diese dann ins StaxRip. Das macht mir ein im Vergleich winziges .avi, welches ich dann als reines Video, also ohne Ton, ins Magix lade. Der dazugehörige Ton der US-Tonspur kommt, sofern benötigt, von der o.g. .ac3, mit BeSweet zur .wav gewandelt.

  • Also, ich habe mir Smallville Staffel 1 von iTunes geladen. Das Video hat 23.976 fps und die Audio Datei ist eine mp4a Datei. Habe mit dem Tsmuxer audio und video getrennt und die Audio Datei mit Besweet in wav umgewandelt.


    Jetzt will ich das eng Video mit der dt Tonspur (hier von serienjunkies habe ich die dt xvid Dateien) versehen. Habe ebenfalls die avi Datei in video und Audio getrennt und die Dateien in magix eingeführt.


    Die eng wav und die dt audio und video Datei lassen sich problemlos importieren nur die eng Video Spur nicht. Das ist das Problem.

  • In welchem Format hast Du denn die englische Videospur vorliegen? .264? Ich weiß gar nicht, ob Magix das Fomat überhaupt kennt/akzeptiert, habe ich noch nie probiert. Ich lasse StaxRip immer ein XviD davon machen und das nimmt Magix ohne zu murren...

  • Ich habe die .264 Datei mit dem TSMuxer in eine Ts und alternativ in eine m2ts Datei umgewandelt. Magix lädt die Datei, erkennt sie dann aber nicht richtig. Die geladenen Datei dauert nur 1 sec

  • Dann wähle in tsMuxer doch mal bei "Output" die Option "Demux" aus. Dann bekommst Du die Date ansonsten unverändert ausgegeben, nur eben getrennt in video und audio. Das video als .264 datei, welche z. B. StaxRip zu einem XviD konvertieren kann (inklusive speedup auf 25fps, bei Bedarf). Dieses kann Magix dann ohne Probleme "futtern" :-)

  • MacLeod


    Gut, dass du es geschrieben hast. Das hatte ich aber auch schon versucht. Beim Import des Virtuellen avi kommt gleich ein Fehlerhinweis. Sprich der File wird gar nicht geladen.


    Ich kanns mir nicht erklären. Bei Win xp lief alles noch 100%. Aber, ob es jetzt wirklich an Win 7 liegt, weiß ich nicht.

  • Ich schreibe das mal in dem etwas älteren Trade weil ich ein ähnliches problem habe!


    Quote from grey;274832

    Dann wähle in tsMuxer doch mal bei "Output" die Option "Demux" aus. Dann bekommst Du die Date ansonsten unverändert ausgegeben, nur eben getrennt in video und audio. Das video als .264 datei, welche z. B. StaxRip zu einem XviD konvertieren kann (inklusive speedup auf 25fps, bei Bedarf). Dieses kann Magix dann ohne Probleme "futtern" :-)


    Wenn ich die TS und das Videofile mit tsMuxxer demuxxe ist die TS einwandfrei, nur mit dem Videofile habe ich probleme!


    Die .264 lässt sich einfach nicht abspielen, weder mit VLC noch mit MPC
    woran kann das liegen, im MP4 Container lief das Teil doch einwandfrei?
    Filegrösse stimmt auch!


    Könnte da echt was Hilfe gebrauchen!

    Gruß: Zeg


    >>======>


    Ich hoffe das ich bald wieder mehr Zeit fürs Board habe! Zeg

  • Die "nackte" .264 kannste meines Wissens auch so mit nix abspielen. Vielmehr musst Du die, z. B. mit MKVMerge, zusammen mit der/den gewünschten Tonspur(-en) zu einer .mkv verarbeiten.

  • mkv nützt mir nicht, kann man die nicht in eine avi packen und wenn das nicht geht muss ich die in Xvid konvertiren zur Not ich brauche das zum dubben und möchte es danach auch noch mit VirtualDubMod bearbeiten (TS einfügen)?

    Gruß: Zeg


    >>======>


    Ich hoffe das ich bald wieder mehr Zeit fürs Board habe! Zeg

  • Ja,


    Quote

    und wenn das nicht geht muss ich die in Xvid konvertiren zur Not ich brauche das zum dubben


    das ist beim dubben auch die übliche Vorgehensweise, also die .264 (z. B. mit Staxrip) nach XviD zu konvertieren. Das resultierende AVI kannste dann ins Magix laden zum dubben.